Monday, 12 June 2017

Update 20.1.2, the store and game launcher drama

The latest update on May 31 was intended to fix the in-game store, but had some serious side effects for a lot of players, with both Windows and Linux affected.

Basically, from what I understand, the in-game store uses some third-party software and the third-party changed their code to comply with some new legal requirements and Standing Stone Games had to change their code to maintain compatibility. While they worked on the changes, they implemented an external store for LOTRO in the web browser, but when they switched to the new in-game store using a Chromium Embedded Framework, older operating systems, such as 32-bit Windows XP and Vista as well as Linux systems using 32-bit Wine, did not support it, which caused critical errors and crashes upon launching LOTRO and clicking the Play button.

At the same time, there was also a problem with 64-bit Windows 7/8/10 systems that seemed to have the same outcome - the game crashed on launch - but a different cause. It was found to be due to a conflict with a third-party graphics utility called SweetFX, and removing SweetFX fixed the issue for many. Some people suggested ReShade (which works with LOTRO) as a replacement for SweetFX.

While ideally these issues would have been caught in QA testing before launching the Update, SSG started investigating the issues pretty quickly and kept providing feedback and suggestions in the forums, but the community was also great at trying to narrow down the root cause (although there were a few who decided to ridicule people using older operating systems which wasn't helpful).

Suggestions for fixing the issue included:
  • renaming/relocating the UserPreferences.ini file (didn't work)
  • restore default settings in the launcher options (didn't work)
  • run game as admin (didn't work)
  • reinstalling the game (didn't work)
  • removing d3d9.dll from the LOTRO game directory (worked for some people with Windows 7+, probably as it was a dependency for SweetFX)
  • changing Wine version to 2.7-staging or later and OS from Windows 7 to Windows 8.1, and using OpenGL (worked for some people using Linux - but not for me)

Within 48 hours of the Update, the developers had new launcher and client files for affected players to download and copy into the LOTRO game directory (also recommended to backup the original launcher configuration file first). Reports started coming in pretty quickly that it worked for most people with Windows and Linux (worked for me).

So LOTRO worked for a few days until June 6, then they did server maintenance to implement some bugfixes and the game launcher crashed again - this time with an error message saying "You don't have the current version of the client." The solution was to download and install a newer version of the launcher and client files from the same place as before (but clear your internet cache/use incognito or private mode/use different browser to make sure you don't re-download the old versions). This worked, but I hope we don't have to do this every time they update the game.

Also, I'm still having to use the external browser to visit the store with no option to choose between the in-game store or the external store in the UI Settings or the UserPreferences.ini file. I'm using Linux Mint 18 and PlayOnLinux with Wine version 2.8, Windows 7 compatibility and DirectX 9. I've also tried Wine 2.7-staging, Wine 2.9-staging (with OpenGL, CSMT or default rendering settings) and Windows 8.1 compatibility but it made no difference to the store. DirectX 11 support in Wine is improving (I can play Elder Scrolls Online now, but with graphics glitches) but not complete yet, and I don't think changing to DirectX 11 will fix the store issue. I would like to have a working in-game store soon.

LOTRO is playable again, but they really need to get a permanent fix for these issues. It's putting me off playing LOTRO at the moment because I don't know if the game is going to work or if I'm going to have to go hunting for work-arounds, or if I'll have to wait for the next patch.

*Update 22/6/17: Tried to log into LOTRO and there has been a patch. First it told me that it could not save the data files, so I reset the launcher options to default. It patched ok and logged in, then crashed with the error message about "You don't have the current version of the client." I re-downloaded the launcher and client files (I've put shortcuts to the download links on my browser toolbar - looks like I might need them frequently), put them in the LOTRO folder, restarted the launcher and then the game worked.

*Update 29/6/17: Another patch, another crash and error message about not having the correct version. This time I only downloaded the lotroclient_awesomium.exe file and moved it to the LOTRO folder, then restarted the launcher and the game worked.

*Update 3/8/17: Update 21 and the Mordor expansion released and the game worked fine straight away, but the store still opens in the external browser. However, I ended up reinstalling LOTRO on my other computer and it crashed to desktop after clicking the Play button. I downloaded the launcher and client files from the website, then the game automatically patched them (apparently they weren't up to date), then the game worked on that computer too. So those files are still critical for linux players and we're still stuck with the external game store.

No comments:

Post a Comment